AttributeError: ‘module’ object has no attribute ‘DeprecatedIn12’

If you are playing with certbotĀ on CenOS7 and you encounter the thing below, it’s due to a Python library that should be upgraded:

AttributeError: ‘module’ object has no attribute ‘DeprecatedIn12’

pip install cryptography –upgrade

pip install –upgrade pip

then again:

pip install cryptography –upgrade

After this, you should be able to use certbot without any issues.

Leave a Reply

Your email address will not be published. Required fields are marked *

CommentLuv badge