AttributeError: ‘module’ object has no attribute ‘DeprecatedIn12’

If you are playing with certbot on CenOS7 and you encounter the thing below, it’s due to a Python library that should be upgraded:

AttributeError: ‘module’ object has no attribute ‘DeprecatedIn12’

pip install cryptography –upgrade

pip install –upgrade pip

then again:

pip install cryptography –upgrade

After this, you should be able to use certbot without any issues.

FREEBSD_INSTALL failed with error 19

Finally i managed to sort this one out. I was installing a FreeBSD 10 box, and after the kernel loads, i got this error.

The fix is not really hard, all you need to do is wait about 10 – 20 seconds, and afterwards type in the correct boot sequence:

mountroot> cd9660:/iso9660/FREEBSD_INSTALL

Afterwards the kernel will load and the installation will start

Fatal error: Error: cannot open phar php-5.2.10

If you’re compiling php 5.2.10 and you get this error, you probably are trying to install pear also:

Fatal error: Error: cannot open phar “/root/kit/php-5.2.10/pear/install-pear-nozlib.phar” in /root/kit/php-5.2.10/pear/install-pear-nozlib.phar on line 795

There are 3 solutions for this:

1 – get the latest snapshot of php 5.2.10, from http://snaps.php.net/ which solves this bug,

2 – install php without pear and curlwrappers.

3 – downgrade back to php 5.2.9

I find solution 1 to be the best there is. Seems that upgrade is not always as easy as it should be.

youtube are o zi proasta

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache Server at www.youtube.com Port 80

configure: error: Cannot find OpenSSL’s – freebsd

configure: error: Cannot find OpenSSL’s <evp.h> freebsd

usually you get this error if openssl path is not specified when compiling php i got this error when compiling php-5.2.9.

solution:

cd /usr/ports/security/openssl

make install distclean

then add –with-ssl=/usr to the ./configure line for php.

should work like a charm

Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion

Sometimes, when installing Subversion, you get this error:

[email protected] [~]# yum -y install subversion
Loading “fastestmirror” plugin
Loading mirror speeds from cached hostfile
* base: pubmirrors.reflected.net
* updates: mirrors.gigenet.com
* addons: yum.singlehop.com
* extras: mirror.steadfast.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
–> Running transaction check
—> Package subversion.x86_64 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
–> Processing Dependency: neon >= 0.25.5-6.el5 for package: subversion
—> Package subversion.i386 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
–> Processing Dependency: libneon.so.25 for package: subversion
–> Processing Dependency: libapr-1.so.0 for package: subversion
–> Processing Dependency: libaprutil-1.so.0 for package: subversion
–> Running transaction check
—> Package neon.x86_64 0:0.25.5-10.el5 set to be updated
—> Package subversion.x86_64 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
—> Package subversion.i386 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
—> Package neon.i386 0:0.25.5-10.el5 set to be updated
—> Package apr.i386 0:1.2.7-11 set to be updated
—> Package apr-util.i386 0:1.2.7-7.el5 set to be updated
–> Processing Dependency: libpq.so.4 for package: apr-util
–> Running transaction check
—> Package subversion.x86_64 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
—> Package postgresql-libs.i386 0:8.1.11-1.el5_1.1 set to be updated
—> Package subversion.i386 0:1.4.2-4.el5 set to be updated
–> Processing Dependency: perl(URI) >= 1.17 for package: subversion
–> Finished Dependency Resolution
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion

Quick Solution:

wget http://rpm.evopanel.net/rpms/perl-URI-1.35-3.noarch.rpm

rpm -ihv perl-URI-1.35-3.noarch.rpm

yum -y install subversion

done.

gpac osmozilla – compile error

While compiling gpac, on several systems, you may get the following error:

osmozilla.cpp:793: error: ânsrefcntâ does not name a type
osmozilla.cpp:799: error: ânsrefcntâ does not name a type
osmozilla.cpp:811: error: ânsresultâ does not name a type
make[2]: *** [osmozilla.o] Error 1
make[2]: Leaving directory `/root/video-stuff/gpac/applications/osmozilla’
make[1]: *** [apps] Error 2
make[1]: Leaving directory `/root/video-stuff/gpac/applications’
make: *** [apps] Error 2

Fix is simple:

edit applications/Makefile and comment out the following lines:

#INSTDIRS+=osmozilla
#APPDIRS+=osmozilla

Should get you running

How do I fix this “ALTER TABLE smf_smileys ORDER BY LENGTH” error I am getting?

While upgrading and possibly editing smileys in the Smileys section of your Administration Panel, you may get an error similar to this:

Quote

This query:
ALTER TABLE smf_smileys
ORDER BY LENGTH(code) DESC;
Caused the error:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘LENGTH(code) DESC’ at line 2
There are two solutions to resolve this error.

The first solution will fix both the issue with upgrading, as well as an issue with editing smileys in the Smileys and Message Icons section of your admin panel.
All you need to do is update your MySQL version. To update MySQL yourself, you will have to have server access. Otherwise, and more commonly the case, you will have to ask your host to upgrade MySQL on the server for you. Some older versions of MySQL seem to have this issue. At the moment the MySQL versions known with this are:

  • 5.0.37
  • 5.0.41
  • 5.0.42
  • 5.1.17(Unconfirmed)

There may be other versions of MySQL that have this issue as well, but upgrading MySQL to the latest version for the MySQL branch you are using may resolve the issue.

The second way to resolve this for upgrading is to open “upgrade_1-1.sql” with a text editor and find the following:

Code:

ALTER TABLE {$db_prefix}smileys
ORDER BY LENGTH(code) DESC;

Replacing this with:

Code:

ALTER TABLE {$db_prefix}smileys
ORDER BY code DESC;

For editing smileys in the Smileys and Message Icons section of your admin panel, open “/Sources/ManageSmileys.php” with a text editor and find the following code:

Code:

			// Sort all smiley codes for more accurate parsing (longest code first).
			db_query("
				ALTER TABLE {$db_prefix}smileys
				ORDER BY LENGTH(code) DESC", __FILE__, __LINE__);

Replacing this with:

Code:

			// Sort all smiley codes for more accurate parsing (longest code first).
			db_query("
				ALTER TABLE {$db_prefix}smileys
				ORDER BY code DESC", __FILE__, __LINE__);

This section of code will appear twice in “/Sources/ManageSmileys.php“, You will find this approximatively on lines 654 and 990.

Source