Shared object “libstdc++.so.6″ not found, required by “arcconf”

    The error below, happens usually on FreeBSD10:

    Shared object “libstdc++.so.6″ not found, required by “arcconf”

    The problem with this, is that the binaries are compiled by Adaptec. The solution is pretty easy tho:

    cd /usr/ports/misc/compat9x && make install distclean 

    Done, your arcconf utility is now working.

    Tags: , , ,

    libicui18n.so.52, needed by /usr/local/lib/liblqr-1.so.3

    If you get:

    libicui18n.so.52, needed by /usr/local/lib/liblqr-1.so.3

    This happens because icu has been upgraded to .53. Reading /usr/ports/UPDATING is your friend.

    How to work it out ?

    If you use portmaster:
    portmaster -w -r icu
    If you use portupgrade:
    portupgrade -fr devel/icu
    If you use pkgng with binary packages:
    pkg install -fR devel/icu

    Easy fix as usual

    Tags: , , , ,

    doesn’t install the Apache module anymore: update your OPTIONS and build www/mod_php5 port instead

    Another thing i came upon today, which happens to have an easy fix, is this:

    When you upgraded your ports, and some option got changed, you will probably get:

    doesn’t install the Apache module anymore: update your OPTIONS and build www/mod_php5 port instead

    Now, since you already upgraded the ports tree, the option that you should uncheck and reconfigure the port is already gone, so you can’t fix it like that.

    What you can do, is remove and reconfigure ports options, in my case being the php5-extensions

    What i did was:

    cd /usr/ports/lang/php5-extensions

    make rmconfig-recursive

    then:

    make config-recursive

    You will be prompted to reconfigure the options, and your upgrading will work just fine

    Tags: , ,

    Activate FreeBSD ipfw without recompiling the kernel

    This has been bugging me quite a bit, i used to recompile the kernel every time just to add ipfw support.

    In FreeBSD 10, you can do it without rebuilding the kernel:

    net.inet.ip.fw.default_to_accept=”1″
    ipfw_load=”YES”

    Add the above to /boot/loader.conf – create the file if it’s not already there.

    Reboot and you’re good to go!

    Tags: , , , ,

    FREEBSD_INSTALL failed with error 19

    Finally i managed to sort this one out. I was installing a FreeBSD 10 box, and after the kernel loads, i got this error.

    The fix is not really hard, all you need to do is wait about 10 – 20 seconds, and afterwards type in the correct boot sequence:

    mountroot> cd9660:/iso9660/FREEBSD_INSTALL

    Afterwards the kernel will load and the installation will start

    Tags: , , , ,

    cups-client-1.7.2 conflicts with cups-image-1.5.4_1 (installs files into the same place)

    If you are getting the error below while trying to upgrade ports:

    cups-client-1.7.2 conflicts with cups-image-1.5.4_1 (installs files into the same place)

    This happens because of the cups-image dependencies have been changed. The fix is pretty easy:

    pkg delete -f cups-image\*

    Now you can upgrade the cups-client and ghostscript ports without issues.

    Enjoy

    Tags: , , , , ,

    py27-setuptools27-2.0.1 conflicts with py27-setuptools-2.0.1 (installs files into the same place)

    If you’re getting :

    py27-setuptools27-2.0.1 conflicts with py27-setuptools-2.0.1 (installs files into the same place).

    when you are trying to upgrade ports on a FreeBSD installation, this happens because the dependencies were changed.

    A quick easy fix is:

    pkg set -o devel/py-setuptools:devel/py-setuptools27
    cd /usr/ports/devel/py-setuptools27
    make deinstall
    make reinstall

    Enjoy

    Tags: , , ,

    Upgrade perl 5.12 / 5.14 to 5.16 or later on FreeBSD – How to

    So if you’re me, and you’re using ports for everything on a FreeBSD server, you will notice pretty soon that the perl is kinda out of date, compared to current.

    What can we do about it ? It’s fairly easy but it took a few trial and errors till i got the things rolling:

    pkg set -o lang/perl5.14:lang/perl5.16 or pkg set -o lang/perl5.12:lang/perl5.16

    portupgrade -o lang/perl5.16 -f perl-5.14.\* or  portupgrade -o lang/perl5.16 -f perl-5.12.\*

    portupgrade -rf perl*

    Do, did, done

    Tags: , , , , , ,

    RVM How To

    This is the easiest stuff ever:

    curl -sSL https://get.rvm.io | bash
    
    

    [root@SG2 ~]# rvm install 1.9.3

    Searching for binary rubies, this might take some time.
    Found remote file https://rvm.io/binaries/centos/5/x86_64/ruby-1.9.3-p484.tar.bz2
    Checking requirements for centos.
    Installing requirements for centos.
    Updating system.
    Installing required packages: libyaml-devel, libffi-devel………
    Requirements installation successful.
    ruby-1.9.3-p484 – #configure
    ruby-1.9.3-p484 – #download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 10.3M 100 10.3M 0 0 3253k 0 0:00:03 0:00:03 –:–:– 3320k
    ruby-1.9.3-p484 – #validate archive
    ruby-1.9.3-p484 – #extract
    ruby-1.9.3-p484 – #validate binary
    ruby-1.9.3-p484 – #setup
    ruby-1.9.3-p484 – #making binaries executable.
    ruby-1.9.3-p484 – #downloading rubygems-2.2.2
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 404k 100 404k 0 0 2886k 0 –:–:– –:–:– –:–:– 9.8M
    No checksum for downloaded archive, recording checksum in user configuration.
    ruby-1.9.3-p484 – #extracting rubygems-2.2.2.
    ruby-1.9.3-p484 – #removing old rubygems.
    ruby-1.9.3-p484 – #installing rubygems-2.2.2……………
    ruby-1.9.3-p484 – #gemset created /usr/local/rvm/gems/ruby-1.9.3-p484@global
    ruby-1.9.3-p484 – #importing gemset /usr/local/rvm/gemsets/global.gems..
    ruby-1.9.3-p484 – #generating global wrappers.
    ruby-1.9.3-p484 – #gemset created /usr/local/rvm/gems/ruby-1.9.3-p484
    ruby-1.9.3-p484 – #importing gemsetfile /usr/local/rvm/gemsets/default.gems evaluated to empty gem list
    ruby-1.9.3-p484 – #generating default wrappers.
    [root@SG2 ~]# ruby -v
    ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]

    Tags: , , , ,

    RVM style multiple Python versions on the same server – Centos5

    Hi, so i need to setup some services that use Python 2.7.6, however, since i am using the same Centos5.10 machines that i can’t reload, and i don’t really need to reload them since they are working fine (don’t fix what’s not broken), and on Centos5 you have 2.4.3, and if you decide to upgrade it, you will most likely screw a lot of things in the process, here’s a nice tutorial on how to work things out, using a similar approach to Ruby’s Version Manager or RVM:

    1 – Create a user of your choosing, and login as said user.

    2 - git clone git://github.com/yyuu/pyenv.git .pyenv

    3 – Add env variables to your bash profile (i assume you should be using the bash shell, if you’re using another shell not sure how that goes):

    echo ‘export PYENV_ROOT=”$HOME/.pyenv”‘ >> ~/.bash_profile
    echo ‘export PATH=”$PYENV_ROOT/bin:$PATH”‘ >> ~/.bash_profile
    echo ‘eval “$(pyenv init -)”‘ >> ~/.bash_profile

    4 – Logout and relog, or restart shell. I find relog to be the choice for me as i usually have consoles opened for long periods of time, so i might forget and control+D and then miss my settings and wonder why.

    5 – Install the Python version you need!

    pyenv install 2.7.6

    6 – Setup your new installed version as default:

    pyenv local 2.7.6

    7 – Enjoy your new Python installation!

    Tags: , , , , , ,